Fallo das actualizacións automáticas en WordPress? Fallo fallo?

WordPressRecentemente tivemos un cliente que configurou os seus propios servidores para usalos con WordPress. Cando o recente Seguridade 3.04 chegou a actualización, había certa sensación de urxencia ao instalar esta versión en todos os nosos clientes. Non obstante, este cliente en particular sempre requiriu que actualicemos WordPress manualmente ... un proceso que non é para os débiles.

Non conseguiríamos o típico "non pode escribir ficheiros”Erro neste blog. Pola contra, proporcionáronnos unha pantalla con inicio de sesión FTP. O problema era que cubririamos as credenciais FTP e así sería aínda fracasan... esta vez baseado en boas credenciais.

Púxenme en contacto cos nosos amigos de Lifeline Data Centers, Indiana maior centro de datos, xa que teñen algúns frikis de Apache e configuraron os seus propios servidores. Proporcionáronme unha solución sinxela: engadir as credenciais FTP directamente dentro do wp-config.php arquiva para codificar as credenciais FTP:

define ('FTP_HOST', 'localhost'); define ('FTP_USER', 'nome de usuario'); define ('FTP_PASS', 'contrasinal');

Por algunha razón, as credenciais idénticas que non funcionaron no formulario funcionaron perfectamente cando se introduciron no ficheiro de configuración. Tamén fai que WordPress actúe como faría sen necesidade de FTP ... só tes que facer clic en Actualizar e listo.

4 Comentarios

  1. 1

    Eu experimentei erros de actualización automática de WordPress despois de reconstruír o meu servidor e facer unha nova instalación de WordPress. O meu problema xurdiu de Firefox, non de WordPress; outros poden experimentar o mesmo problema se o seu nome de usuario FTP e o nome de usuario de WordPress son os mesmos que os meus (aínda que con maiúsculas e contrasinais diferentes).

    O problema é que Firefox, se tes activado "Lembrar contrasinais", corrixirá automaticamente o usuario/pasará o formulario para o que pensa que debería estar baseado no que está almacenado no xestor de contrasinais. No meu caso, as miñas credenciais de WordPress gardáronse, pero as miñas credenciais de FTP non, xa que se poden usar para SSH no sitio. As persoas que se atopen nesta situación poden desactivar temporalmente "lembrar contrasinais" nas súas Preferencias/Opcións ao intentar usar a actualización automática de WordPress ou aplicar un anaco de código a WordPress para corrixir este comportamento.

  2. 2

    Doug,

    Tiven o mesmo problema cunha compilación doméstica de Apache. Resulta que foi o resultado de permisos e propiedade inadecuados en certos ficheiros e directorios.

    http://robspencer.net/auto-update-wordpress-without-ftp/

    A ligazón anterior proporcionou información sobre como corrixir o problema sen usar as credenciais ftp. Por suposto, non recomendo que cambies todo o teu directorio de usuarios a 775 (e non o fixen), pero isto levoume na dirección correcta.

    Adán

  3. 3

    Para outros que buscan posibles solucións: outro blogueiro resolveu os seus problemas de actualización automática ao forzar ao seu anfitrión a usar php5 engadindo o seguinte ao seu ficheiro .httaccess:

    AddType x-mapp-php5 .php

  4. 4

    Grazas por compartir o coñecemento, experimentei problemas coas actualizacións automáticas, pero a única solución que atopei é desactivar os complementos, actualizar automaticamente WordPress e, finalmente, reactivar todos os complementos.

    Este consello é para un problema diferente, pero é bo saber como resolvelo.

    Saúdos dende México!

¿Que pensas?

Este sitio usa Akismet para reducir o spam. Aprende a procesar os teus datos de comentarios.